You are Unregistered, please register to gain Full access.    

Go Back   SiNfuL iPhone > Device Specific > iPhone 4

Notices

iPhone 4 iPhone 4 Discussion | Help
NO JAILBREAKING QUESTIONS!

Reply
Thread Tools

 Help: Internet Tethering - MyWi 4.8.3 (Self-Assigned IP)
Unread 10-22-2010, 05:47 AM   #1
aficionado
iPhoneaholic
 
aficionado is offline
Join Date: May 2010
Device: iPhone 4
iOS Version: 4.1
iTunes Version: iTunes 10
Carrier: o2
OS: Windows XP
Location: cardiff
Posts: 148
Thanks: 356
Thanked 21 Times in 13 Posts
Help: Internet Tethering - MyWi 4.8.3 (Self-Assigned IP)

Hi all

I am using iPhone 4 iOS 4.1. I installed MyWi 4.8.3 and managed to get it cracked and working (I think!!).

When I connect it to my Mac using USB, to use my 3G connection, I can't get access to the internet. When I check in the system preferences>network in my Mac, the status is connected, but with orange sign (not green!!) with this description:
Code:
iPhone USB has a self assigned IP address
and will not be able to connect to the internet
It worked when I was using 4.0.1..

Please anyone help me..

Last edited by aficionado; 10-26-2010 at 08:57 AM.
  Reply With Quote

 
Unread 10-22-2010, 08:45 AM   #2
Dogma
Ghost in the Machine
 
Dogma's Avatar
 
Dogma is offline
Join Date: Aug 2009
Device: iPhone 5
iOS Version: 7.0
iTunes Version: iTunes 10
Carrier: AT&T
OS: Windows 7
Location: TX
Posts: 1,046
Thanks: 221
Thanked 805 Times in 287 Posts
Try PDAnet or TetherMe
"Well, it took a lot of work to be the ass that I am
And I'm really damn sure that anyone can, equally,
easily, fuck you over." -Modest Mouse



I'm available through iMessage:
DogmaJones.iPhone@gmail.com
  Reply With Quote

 
Unread 10-23-2010, 10:12 AM   #3
aficionado
iPhoneaholic
 
aficionado is offline
Join Date: May 2010
Device: iPhone 4
iOS Version: 4.1
iTunes Version: iTunes 10
Carrier: o2
OS: Windows XP
Location: cardiff
Posts: 148
Thanks: 356
Thanked 21 Times in 13 Posts
Quote:
Originally Posted by Dogma View Post
Try PDAnet or TetherMe
Thanks..I got it working using PdaNet

But it says 'PdaNet Free Edition' in Cydia. Is it really free? Then why there is 'Register' button in PdaNet? Is this free edition for trial only?

Many thanks
  Reply With Quote

 
Unread 10-23-2010, 04:35 PM   #4
aficionado
iPhoneaholic
 
aficionado is offline
Join Date: May 2010
Device: iPhone 4
iOS Version: 4.1
iTunes Version: iTunes 10
Carrier: o2
OS: Windows XP
Location: cardiff
Posts: 148
Thanks: 356
Thanked 21 Times in 13 Posts
Now I managed to get MyWi working

I installed MyWi crack from insanelyi and follow its instructions..and now everything is working fine

We'll see how it goes..
  Reply With Quote

 
Unread 10-23-2010, 06:10 PM   #5
tc2664
Love this site
 
tc2664's Avatar
 
tc2664 is offline
Join Date: Jul 2010
Device: iPhone 5
iOS Version: 6.1
iTunes Version: iTunes 10
Carrier: AT&T
OS: Mac OS X
Location: CA
Posts: 1,231
Thanks: 76
Thanked 243 Times in 171 Posts
All Mywi crack here are too buggy, you need reboot/respring almost every 2 or 3 days, kinda PIA, I switch to PDAnet, and the crack is easy install, and work smoothly so far
  Reply With Quote

 
Unread 10-24-2010, 01:42 PM   #6
aficionado
iPhoneaholic
 
aficionado is offline
Join Date: May 2010
Device: iPhone 4
iOS Version: 4.1
iTunes Version: iTunes 10
Carrier: o2
OS: Windows XP
Location: cardiff
Posts: 148
Thanks: 356
Thanked 21 Times in 13 Posts
I agree..but PdaNet needs a desktop client for using USB mode. That's why I prefer MyWi..more straight forward in USB mode.

Last edited by aficionado; 10-26-2010 at 09:00 AM.
  Reply With Quote

 
Unread 10-26-2010, 09:01 AM   #7
aficionado
iPhoneaholic
 
aficionado is offline
Join Date: May 2010
Device: iPhone 4
iOS Version: 4.1
iTunes Version: iTunes 10
Carrier: o2
OS: Windows XP
Location: cardiff
Posts: 148
Thanks: 356
Thanked 21 Times in 13 Posts
Update: The same problem with USB tethering mode reappeared

Anyone can help?

No problem with wifi tethering though..
  Reply With Quote

 
Unread 10-26-2010, 09:36 AM   #8
keyes
Master Coder
 
keyes is offline
Join Date: Aug 2010
Device: iPhone 5
iOS Version: 6.1
iTunes Version: iTunes 11
Carrier: AT&T
OS: Mac OS X
Location: MD
Posts: 145
Thanks: 1
Thanked 55 Times in 14 Posts
I have both tetherme and mywi (paid) and have no problems on my MacBook pro.

Make sure everything on your computer is up to date and you have the latest versions of the apps running on your phone and report back.
Contact me via Board PM or Skype if I don't get back to you in 24-48 hours.

  Reply With Quote

 
Unread 11-01-2010, 06:48 AM   #9
aficionado
iPhoneaholic
 
aficionado is offline
Join Date: May 2010
Device: iPhone 4
iOS Version: 4.1
iTunes Version: iTunes 10
Carrier: o2
OS: Windows XP
Location: cardiff
Posts: 148
Thanks: 356
Thanked 21 Times in 13 Posts
i am using the cracked version..still doesn't work..tbh, sometimes it works, sometimes doesn't..
  Reply With Quote

 
Unread 02-10-2011, 11:35 AM   #10
stekhh
n00b ???
 
stekhh is offline
Join Date: Jan 2011
Device: iPhone 4
iOS Version: 4.3
iTunes Version: iTunes 10
Carrier: Other
OS: Mac OS X
Location: Malaysia
Posts: 2
Thanks: 3
Thanked 0 Times in 0 Posts
same problem here....all not working except wifi tethering
  Reply With Quote

 
Unread 07-15-2012, 03:48 PM   #11
phatturtle
n00b
 
phatturtle's Avatar
 
phatturtle is offline
Join Date: Jun 2012
Device: iPhone 3G
iOS Version: 4.1
iTunes Version: iTunes 10
Carrier: AT&T
OS: Mac OS X
Location: Michigan
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
iPhone 3G, version 4.2.1 (Jailbroken and using full version pdaNet) and iMac 10.6.8

I have been trying to use the hotspot, but can only get about 10-15 minutes of service, before I get an error from the iMac "Self-assigned ip address, will not be able to connect to the internet".

I am new to jailbreaking and posting messages. BUT I have been to so many forums with the same 'self-assigned' error I am getting, I have tried everything but whatever it is I need to do to actually correct this! I have, updated things, deleted, re-jailbreaking, etc. I talked to a group of teens in the mac section of Walmart and several people at Best Buy. Posted questions on facebook too!

I don't know if this is an iMac problem, or an iPhone problem. WHEN it is throwing out the hotspot, even a windows laptop and an iPod 4 touch starts picking up the signal. When my iMac starts up with the 'self-assigned' error, everyone loses connections, EVEN though the phone still says "internet ready"

I also have tried to tether and untether, both end up with the same result. Bluetooth on, and off, hide tether on and off, manually creating a random ip address and throwing one it was using a day or so prior, renewing, etc.

Don't know if this means anything, but I do live in the black hole. We only receive a signal in the corner of one window, standing on the tippy-toes. So we have to drop the iphone into an onion bag and duct tape it to the window.....(not a joke it works), the signal is strong enough to get a 3G and 4 out of 5 bars! ... sucks if you want to make a call

That being said, I know that the signal you receive is only as good as the signal the phone can blast thru the house, so rather then attempt it, I have relocated the iMac to the same room, but still get the same problem. I have attempted to Pair the two, although the iMac is up for it, the iphone turns him down. Heard these two things could be part of the issue, at this point I would cluck like a chicken if someone said it worked for them!

Thanks for ANY help I have been working on this since APRIL!!!! Wendy

---------- EDIT ----------

oh my gosh, can't believe I just posted this in the iphone 4. I am so sorry. Now I am certain I am the dumbest person in the forum. Do I repost this to iPhone 3g or is that something Sinful iphone does?
  Reply With Quote

 
Unread 07-15-2012, 04:47 PM   #12
cooldayr
Obsessive iPhone Disorder
 
cooldayr's Avatar
 
cooldayr is offline
Join Date: Jun 2011
Device: iPhone 5S
iOS Version: 7.0
iTunes Version: iTunes 11
Carrier: T-Mobile
OS: Hackintosh
Location: Connecticut
Posts: 2,527
Thanks: 62
Thanked 1,675 Times in 886 Posts
Quote:
Originally Posted by phatturtle View Post
iPhone 3G, version 4.2.1 (Jailbroken and using full version pdaNet) and iMac 10.6.8

I have been trying to use the hotspot, but can only get about 10-15 minutes of service, before I get an error from the iMac "Self-assigned ip address, will not be able to connect to the internet".

I am new to jailbreaking and posting messages. BUT I have been to so many forums with the same 'self-assigned' error I am getting, I have tried everything but whatever it is I need to do to actually correct this! I have, updated things, deleted, re-jailbreaking, etc. I talked to a group of teens in the mac section of Walmart and several people at Best Buy. Posted questions on facebook too!

I don't know if this is an iMac problem, or an iPhone problem. WHEN it is throwing out the hotspot, even a windows laptop and an iPod 4 touch starts picking up the signal. When my iMac starts up with the 'self-assigned' error, everyone loses connections, EVEN though the phone still says "internet ready"

I also have tried to tether and untether, both end up with the same result. Bluetooth on, and off, hide tether on and off, manually creating a random ip address and throwing one it was using a day or so prior, renewing, etc.

Don't know if this means anything, but I do live in the black hole. We only receive a signal in the corner of one window, standing on the tippy-toes. So we have to drop the iphone into an onion bag and duct tape it to the window.....(not a joke it works), the signal is strong enough to get a 3G and 4 out of 5 bars! ... sucks if you want to make a call

That being said, I know that the signal you receive is only as good as the signal the phone can blast thru the house, so rather then attempt it, I have relocated the iMac to the same room, but still get the same problem. I have attempted to Pair the two, although the iMac is up for it, the iphone turns him down. Heard these two things could be part of the issue, at this point I would cluck like a chicken if someone said it worked for them!

Thanks for ANY help I have been working on this since APRIL!!!! Wendy

---------- EDIT ----------

oh my gosh, can't believe I just posted this in the iphone 4. I am so sorry. Now I am certain I am the dumbest person in the forum. Do I repost this to iPhone 3g or is that something Sinful iphone does?
Not to mention your bumped a nearly two year old thread
  Reply With Quote

 
Unread 07-16-2012, 04:48 AM   #13
phatturtle
n00b
 
phatturtle's Avatar
 
phatturtle is offline
Join Date: Jun 2012
Device: iPhone 3G
iOS Version: 4.1
iTunes Version: iTunes 10
Carrier: AT&T
OS: Mac OS X
Location: Michigan
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Oh, right, I know. Just searching google with 'self-assigned ip' gives results from threads back to 2003!

This must be one of those symptoms that has multiple possibilities as to the cause. Sort of like telling a dr you have a headache and expecting an answer as to why. I have followed advice from forums dating as far back as 2003 and as recent as feb 2012. My computer is from 2006, so for me, a two year old forums isn't as outdated as they are to those that have newer models.

I did attempt to find a newer chat, but the results from a search on sinful iphone, brought me to this one. It may not even be an iphone problem, I don't know.

I am very awkward with technology and posting to chats. I typically don't bother people online with my troubles, but with school starting up again in a month, I didn't want to go thru another year without a working internet. I am beginning to think it is unsolvable glitch.

At least your reply allowed me to see that someone is watching! Thanks, Wendy
  Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -8. The time now is 01:58 PM.

Copyright 2009 (SiNfulSS)- Shot Caller @ SiNfuL iPhone